Quicktime

Quicktime is usually used for playing movies, but it also has some basic video editing functions that are quite sufficient for most of the scientific visualizations that I need to do. Here are some of these tricks that I've collected.

These features are in Quicktime 7.x, but not the newer version that is default in Snow Leopard. If you have Snow Leopard, you can still download the older version here.

You'll need a Quicktime Pro serial number to unlock these features.

Make a Quicktime movie from an image sequence

(Instructions for saving an image sequence from MATLAB)

  1. Choose File → Open Image Sequence…
  2. Navigate to the folder where you saved the images, and select the first one in the sequence. Click on Open.
  3. Choose a display framerate. This isn't that important since we are going to re-encode the movie anyway. Click OK. Now you should have a movie window open with your image sequence.
  4. We need to convert this simple image sequence into an actual movie format that is compatible with YouTube, Vimeo, etc.. Choose File → Export…
  5. Give the movie a name and then click on the Options button.
  6. Click on the Settings… button and make adjustments as follows:
  7. Click OK and now click on the Size… button. Choose 1280×720 HD.
  8. Now your Settings window should look like this:
  9. Click OK to go back, and then click on Save. Quicktime will work for a bit to convert your movie, which will then be saved in a compact standard format for distribution:

Add a title frame to a Quicktime movie

Add a logo overlay to a Quicktime movie

  1. Make an image in Photoshop (or equivalent) for your logo. It should be:
    • A transparent .png with your logo/text.
    • The same dimensions as the movie (e.g 1280×720 px for a 720p movie).
  2. With the image open in an image editor, select all, and copy it to the clipboard.
  3. Now open the movie in Quicktime and choose Edit → Select All.
  4. Edit → Add to Selection and Scale.
  5. Choose Window → Show Movie Properties.
  6. Select Track 2, which is the overlay that was just added.
  7. Click the Visual Settings tab and choose Straight Alpha in the Transparency dropdown menu.
  8. Close the Movie Properties window and you should have your new transparent logo as a constant overlay while the movie plays in the background.
computing/quicktime.txt · Last modified: 2011/03/25 9:18 am PDT by John Colby
 
Except where otherwise noted, content on this wiki is licensed under the following license: CC Attribution-Noncommercial-Share Alike 4.0 International
Recent changes RSS feed Donate Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki